[gentoo-announce] [ GLSA 201606-02 ] Puppet Server and Agent: Multiple vulnerabilities

Fabricante: Gentoo
Fecha: 05/06/2016
Identificador: GLSA 201606-02
[gentoo-announce] [ GLSA 201606-02 ] Puppet Server and Agent: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - Gentoo Linux Security Advisory GLSA 201606-02 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - https://security.gentoo.org/ - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - Severity: Normal Title: Puppet Server and Agent: Multiple vulnerabilities Date: June 05, 2016 Bugs: #577450, #581372 ID: 201606-02 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - Synopsis ======== Multiple vulnerabilities have been found in Puppet Server and Agent, the worst of which could lead to arbitrary code execution. Background ========== Puppet Agent contains Puppet’s main code and all of the dependencies needed to run it, including Facter, Hiera, and bundled versions of Ruby and OpenSSL. Affected packages ================= ------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 app-admin/puppet-agent < 1.4.2 >= 1.4.2 2 app-admin/puppetserver < 2.3.2 >= 2.3.2 ------------------------------------------------------------------- 2 affected packages Description =========== Multiple vulnerabilities have been discovered in Puppet Server and Agent. Please review the CVE identifiers referenced below for details. Impact ====== Remote attackers, impersonating a trusted broker, could potentially execute arbitrary code. Workaround ========== There is no known workaround at this time. Resolution ========== All puppet-agent users should upgrade to the latest version: # emerge --sync # emerge --ask --oneshot --verbose ">=app-admin/puppet-agent-1.4.2" All puppetserver users should upgrade to the latest version: # emerge --sync # emerge --ask --oneshot --verbose ">=app-admin/puppetserver-2.3.2" References ========== [ 1 ] CVE-2016-2785 http://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-2785 [ 2 ] CVE-2016-2786 http://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-2786 Availability ============ This GLSA and any updates to it are available for viewing at the Gentoo Security Website: https://security.gentoo.org/glsa/201606-02 Concerns? ========= Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org. License ======= Copyright 2016 Gentoo Foundation, Inc; referenced text belongs to its owner(s). The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license. http://creativecommons.org/licenses/by-sa/2.5