[gentoo-announce] [ GLSA 201605-01 ] Git: Multiple vulnerabilities

Fabricante: Gentoo
Fecha: 02/05/2016
Identificador: GLSA 201605-01
[gentoo-announce] [ GLSA 201605-01 ] Git: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - Gentoo Linux Security Advisory GLSA 201605-01 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - https://security.gentoo.org/ - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - Severity: Normal Title: Git: Multiple vulnerabilities Date: May 02, 2016 Bugs: #562884, #577482 ID: 201605-01 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - Synopsis ======== Git contains multiple vulnerabilities that allow for the remote execution of arbitrary code. Background ========== Git is a free and open source distributed version control system designed to handle everything from small to very large projects with speed and efficiency. Affected packages ================= ------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 dev-vcs/git < 2.7.3-r1 >= 2.7.3-r1 Description =========== Git is vulnerable to the remote execution of arbitrary code by cloning repositories with large filenames or a large number of nested trees. Additionally, some protocols within Git, such as git-remote-ext, can execute arbitrary code found within URLs. These URLs that submodules use may come from arbitrary sources (e.g., .gitmodules files in a remote repository), and can effect those who enable recursive fetch. Restrict the allowed protocols to well known and safe ones. Impact ====== Remote attackers could execute arbitrary code on both client and server. Workaround ========== There is no known workaround at this time. Resolution ========== All Git users should upgrade to the latest version: # emerge --sync # emerge --ask --oneshot --verbose ">=dev-vcs/git-2.7.3-r1" References ========== [ 1 ] Buffer overflow in all git versions before 2.7.1 http://seclists.org/oss-sec/2016/q1/645 [ 2 ] CVE-2015-7545 http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-7545 [ 3 ] CVE-2016-2315 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-2315 [ 4 ] CVE-2016-2324 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-2324 Availability ============ This GLSA and any updates to it are available for viewing at the Gentoo Security Website: https://security.gentoo.org/glsa/201605-01 Concerns? ========= Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org. License ======= Copyright 2016 Gentoo Foundation, Inc; referenced text belongs to its owner(s). The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license. http://creativecommons.org/licenses/by-sa/2.5