[security-announce] SUSE-SU-2016:1138-1: important: Security update for yast2-users

Fabricante: SuSe
Fecha: 25/04/2016
Identificador: SUSE-SU-2016:1138-1
[security-announce] SUSE-SU-2016:1138-1: important: Security update for yast2-users
SUSE Security Update: Security update for yast2-users ______________________________________________________________________________ Announcement ID: SUSE-SU-2016:1138-1 Rating: important References: #971804 #973639 #974220 Cross-References: CVE-2016-1601 Affected Products: SUSE Linux Enterprise Software Development Kit 12-SP1 SUSE Linux Enterprise Server 12-SP1 SUSE Linux Enterprise Desktop 12-SP1 ______________________________________________________________________________ An update that solves one vulnerability and has two fixes is now available. Description: yast2-users was updated to fix one security issue. This security issue was fixed: - CVE-2016-1601: Empty passwords fields in /etc/shadow after SLES 12 SP1 autoyast installation (bsc#974220). This update includes a script that fixes installations that we're affected by this problem. It is run automatically upon installing the update. This non-security issue was fixed: - bsc#971804: Set root password correctly when using a minimal profile Patch Instructions: To install this SUSE Security Update use YaST online_update. Alternatively you can run the command listed for your product: - SUSE Linux Enterprise Software Development Kit 12-SP1: zypper in -t patch SUSE-SLE-SDK-12-SP1-2016-669=1 - SUSE Linux Enterprise Server 12-SP1: zypper in -t patch SUSE-SLE-SERVER-12-SP1-2016-669=1 - SUSE Linux Enterprise Desktop 12-SP1: zypper in -t patch SUSE-SLE-DESKTOP-12-SP1-2016-669=1 To bring your system up-to-date, use "zypper patch". Package List: - SUSE Linux Enterprise Software Development Kit 12-SP1 (ppc64le s390x x86_64): yast2-users-debuginfo-3.1.41.3-9.1 yast2-users-debugsource-3.1.41.3-9.1 yast2-users-devel-doc-3.1.41.3-9.1 - SUSE Linux Enterprise Server 12-SP1 (ppc64le s390x x86_64): yast2-users-3.1.41.3-9.1 yast2-users-debuginfo-3.1.41.3-9.1 yast2-users-debugsource-3.1.41.3-9.1 - SUSE Linux Enterprise Desktop 12-SP1 (x86_64): yast2-users-3.1.41.3-9.1 yast2-users-debuginfo-3.1.41.3-9.1 yast2-users-debugsource-3.1.41.3-9.1 References: https://www.suse.com/security/cve/CVE-2016-1601.html https://bugzilla.suse.com/971804 https://bugzilla.suse.com/973639 https://bugzilla.suse.com/974220 --