[security-announce] openSUSE-SU-2016:1073-1: important: Security update for mercurial

Fabricante: SuSe
Fecha: 17/04/2016
Identificador: SUSE-SU-2016:1073-1
[security-announce] openSUSE-SU-2016:1073-1: important: Security update for mercurial
openSUSE Security Update: Security update for mercurial ______________________________________________________________________________ Announcement ID: openSUSE-SU-2016:1073-1 Rating: important References: #973175 #973176 #973177 Cross-References: CVE-2016-3068 CVE-2016-3069 CVE-2016-3630 Affected Products: openSUSE Leap 42.1 ______________________________________________________________________________ An update that fixes three vulnerabilities is now available. Description: mercurial was updated to fix three security issues. These security issues were fixed: - CVE-2016-3069: Arbitrary code execution when converting Git repos (bsc#973176). - CVE-2016-3068: Arbitrary code execution with Git subrepos (bsc#973177). - CVE-2016-3630: Remote code execution in binary delta decoding (bsc#973175). Patch Instructions: To install this openSUSE Security Update use YaST online_update. Alternatively you can run the command listed for your product: - openSUSE Leap 42.1: zypper in -t patch openSUSE-2016-467=1 To bring your system up-to-date, use "zypper patch". Package List: - openSUSE Leap 42.1 (i586 x86_64): mercurial-3.5.1-3.1 mercurial-debuginfo-3.5.1-3.1 mercurial-debugsource-3.5.1-3.1 - openSUSE Leap 42.1 (noarch): mercurial-lang-3.5.1-3.1 References: https://www.suse.com/security/cve/CVE-2016-3068.html https://www.suse.com/security/cve/CVE-2016-3069.html https://www.suse.com/security/cve/CVE-2016-3630.html https://bugzilla.suse.com/973175 https://bugzilla.suse.com/973176 https://bugzilla.suse.com/973177 --