[gentoo-announce] [ GLSA 201502-10 ] libpng: User-assisted execution of arbitrary code

Fabricante: Gentoo
Fecha: 15/02/2015
Identificador: GLSA 201502-10
[gentoo-announce] [ GLSA 201502-10 ] libpng: User-assisted execution of arbitrary code
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - Gentoo Linux Security Advisory GLSA 201502-10 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - http://security.gentoo.org/ - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - Severity: Normal Title: libpng: User-assisted execution of arbitrary code Date: February 15, 2015 Bugs: #531264, #533358 ID: 201502-10 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - Synopsis ======== Two vulnerabilities have been found in libpng, possibly resulting in execution of arbitrary code. Background ========== libpng is a standard library used to process PNG (Portable Network Graphics) images. It is used by several programs, including web browsers and potentially server processes. Affected packages ================= ------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 media-libs/libpng < 1.6.16 >= 1.6.16 *>= 1.5.21 *>= 1.2.52 Description =========== Two vulnerabilities have been discovered in libpng: * The png_user_version_check function contains an out-of-bounds memory access error (libpng 1.6.15 Release Notes) * The png_combine_row function contains an integer overflow error, which could result in a heap-based buffer overflow (CVE-2014-9495) Impact ====== A context-dependent attacker could entice a user to open a specially crafted PNG file using an application linked against libpng, possibly resulting in execution of arbitrary code. Workaround ========== There is no known workaround at this time. Resolution ========== All libpng 1.6 users should upgrade to the latest version: # emerge --sync # emerge --ask --oneshot --verbose ">=media-libs/libpng-1.6.16" All libpng 1.5 users should upgrade to the latest version: # emerge --sync # emerge --ask --oneshot --verbose ">=media-libs/libpng-1.5.21" References ========== [ 1 ] CVE-2014-9495 http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-9495 [ 2 ] libpng 1.6.15 Release Notes http://www.libpng.org/pub/png/src/libpng-1.6.15-README.txt Availability ============ This GLSA and any updates to it are available for viewing at the Gentoo Security Website: http://security.gentoo.org/glsa/glsa-201502-10.xml Concerns? ========= Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org. License ======= Copyright 2015 Gentoo Foundation, Inc; referenced text belongs to its owner(s). The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license. http://creativecommons.org/licenses/by-sa/2.5