[gentoo-announce] [ GLSA 201502-01 ] mpg123: User-assisted execution of arbitrary code

Fabricante: Gentoo
Fecha: 06/02/2015
Identificador: GLSA 201502-01
[gentoo-announce] [ GLSA 201502-01 ] mpg123: User-assisted execution of arbitrary code
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - Gentoo Linux Security Advisory GLSA 201502-01 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - http://security.gentoo.org/ - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - Severity: Normal Title: mpg123: User-assisted execution of arbitrary code Date: February 06, 2015 Bugs: #500262 ID: 201502-01 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - Synopsis ======== A vulnerability has been found in mpg123, which could result in arbitrary code execution. Background ========== mpg123 is a realtime MPEG 1.0/2.0/2.5 audio player for layers 1, 2 and 3. Affected packages ================= ------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 media-sound/mpg123 < 1.18.1 >= 1.18.1 Description =========== An issue has been found in mpg123 when decoding specifically crafted MP3 file, that causes a heap-based buffer overflow. Impact ====== A remote attacker could entice a user to open a specially crafted MPEG file using mpg123, possibly resulting in execution of arbitrary code with the privileges of the process or a Denial of Service condition. Workaround ========== There is no known workaround at this time. Resolution ========== All mpg123 users should upgrade to the latest version: # emerge --sync # emerge --ask --oneshot --verbose ">=media-sound/mpg123-1.18.1" References ========== [ 1 ] CVE-2014-9497 http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-9497 Availability ============ This GLSA and any updates to it are available for viewing at the Gentoo Security Website: http://security.gentoo.org/glsa/glsa-201502-01.xml Concerns? ========= Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org. License ======= Copyright 2015 Gentoo Foundation, Inc; referenced text belongs to its owner(s). The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license. http://creativecommons.org/licenses/by-sa/2.5